Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2025 - 03:00 UTC
Update
Brightwheel will be offline for scheduled maintenance between 8pm - 11:59pm PT on March 14th 2025. During the maintenance window, you will not be able to access the brightwheel app or website and any scheduled notifications will be delayed. We apologize for any inconvenience as we’re working to upgrade our app's performance.
Posted Mar 13, 2025 - 21:58 UTC
Scheduled
Brightwheel will be offline for scheduled maintenance between 8pm - 11:59pm PT on March 14th 2025. During the maintenance window, you will not be able to access the brightwheel app or website and any scheduled notifications will be delayed. We apologize for any inconvenience as we’re working to upgrade our app's performance.
Posted Mar 13, 2025 - 21:57 UTC
This scheduled maintenance affected: iOS App, Android App, Website, and Web App.